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المركز الجامعي لميلة

مدخل تعريفي بمجموعة برامج (SPSS)المحور رقم (02)

(Introduction on SPSS Software)                                        SPSS مقدمة حول مجموعة برامج

(Data input)                                                                                                     إدخال البیانات

(Data editing)                                                                                                  تحریر البیانات

•إدخال البیانات من برامج أخرى• Inputting data from other application programs 

•استحداث/ حساب متغیر جدید• Creating/calculating a new variable 

•البحث في مجموعة فرعیة من الملاحظات• Research on a subset of observations 

•إعادة ترمیز المتغیرات• Recoding variables 

•(SPSS) استحداث البیانات في• Data Creation in SPSS

•تعریف المتغیرات في شاشة عرض المتغیر• Defining Variables in the Variable View

•تقسیم قاعدة البیانات• Splitting the data file 
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مدخل تعريفي بمجموعة برامج (SPSS)المحور رقم (02)

(Introduction on SPSS Software)                                        SPSS مقدمة حول مجموعة برامج

SPSS  (Statistical Package for the Social Sciences)

        Is a widely distributed software program which allows data to be analysed. This 
may involve simple descriptive analyses as well as more advanced techniques, such as 
multivariate analysis. SPSS consists of different modules. This means that in addition 
to the basic module (Base System), there are also other modules. These are normally 
destined for more advanced and specialized analyses (for example, the AMOS module, 
SPSS Data Entry module). SPSS works with different screens for each type of action 
(for example data input, output, programming, etc.). 

Extension
• Data files are indicated by the extension .sav. 
• Output screen is indicated by  extension .spo or .spv. 
• Syntax screen is indicated by  extension .sps.
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مدخل تعريفي بمجموعة برامج (SPSS)المحور رقم (02)

SPSS 1مقدمة حول مجموعة برامج. Opening SPSS 

There are several ways of beginning a session with SPSS, depending upon whether you 
intend to build a new file or to access an old one. When SPSS is opened for the first time 
by clicking the SPSS icon, an opening dialog box will appear with the title SPSS 
Statistics 20

Click to type data 
into the Data Editor
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مدخل تعريفي بمجموعة برامج (SPSS)المحور رقم (02)

SPSS 2مقدمة حول مجموعة برامج.    The SPSS Statistics Data Editor 

1. The Data Editor provides two alternative windows: (Variable View contains the names and details of the variables in the  
data set). (Data View is an array like a spreadsheet, into which the user can either type new data or enter data from a stored file). 
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(3. OUTPUT VIEWER)                                (شاشة العارض) :SPSS مقدمة حول مجموعة برامج

1. The Output Viewer window: is divided into two sections, or frames. The left frame contains an outline of the content in the Output Viewer. This outline is especially useful when you have run many SPSS commands and need to locate a particular section of output easily. The right frame 
contains the actual output.  

2. An Output Viewer window can be saved as: a viewer file (*.spv) so that you can review it again without having to re-run the same commands in SPSS. To save an Output Viewer window, click File > Save As. Alternatively, you can export some or all of the contents in the Viewer window to 
a new document or image file by clicking File > Export. In general, you can export all content as a PDF (*.pdf), a PowerPoint file (*.ppt), an Excel file (*.xls or *.xlsx), a Word file (*.doc or *.docx), an HTML file (*.htm), or a text file (*.txt). Graphs can be saved as *.bmp, *.emf, *.eps, 
*.jpeg, *.png, or *.tif.
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 (4.SPSS Toolbar Shortcuts)                           (شریط الأدوات) :SPSS مقدمة حول مجموعة برامج

Icon Tooltip Description

Open data 
document

Open a datafile. Equivalent to File > Open > Data.

Save this 
document

Save the active dataset. Equivalent 
to File > Save or Ctrl + S.

Print Print the contents of the active data view window. 
Not recommended. Equivalent to File > Print.

Recall recently 
used dialogs

Shows the list of most recently used dialog windows.
Use when you need to re-run an analysis.

Undo a user 
action

Redo a user 
action

Equivalent to Edit > Undo (in the drop-down menus) 
or Ctrl + Z.

Equivalent to Edit > Redo (in the drop-down menus) 
or Ctrl + Y.

1. By default, the Data View window: has the following shortcuts for common tasks.
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 (4.SPSS Toolbar Shortcuts)                (شریط الأدوات)      تابع :SPSS مقدمة حول مجموعة برامج

Icon Tooltip Description

Go to
 case 

Jump to a specific case (row) in the active dataset. 
Equivalent to Edit > Go to Case. 

Go to 
variable

Jump to a specific variable (column) in the active 
dataset.Equivalent to Edit > Go to Variable.

Variables
View the variable name, labels, type, measurement level,
 missing value codes, and value labels for all variables                
 in the active window. Equivalent to Utilities > Variables.

Run 
descriptive
statistics

Variables are summarized with a frequency table; scale 
variables are summarized using mean, median, standard 
deviation, range, minimum, and maximum. Equivalent to 
Analyze > Descriptive Statistics > Frequencies.
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 (4.SPSS Toolbar Shortcuts)               (شریط الأدوات)      تابع :SPSS مقدمة حول مجموعة برامج

Icon Tooltip Description

Split file
Stratify your analyses based on a categorical variable. For 
Exp, if the variable Gender is selected in Split File, running 
descriptive statistics on any other variables will produce 
descriptives for males and females separately. Equivalent to 
Data > Split File.

Find Search for a value or observation in the dataset, or search and 
replace a value or observation in the dataset. 
Equivalent to Edit > Find and Edit > Replace, or Ctrl + F and 
Ctrl + H , respectively. 

Insert 
cases 

Insert a case between two existing cases. 
Equivalent to Edit > Insert Cases. 

Insert 
variable 

Insert a new variable between two existing variables. 
Equivalent to Edit > Insert Variable. 
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 (4.SPSS Toolbar Shortcuts)                (شریط الأدوات)      تابع :SPSS مقدمة حول مجموعة برامج

Icon Tooltip Description

Weight
 cases 

Set a weighting variable.
 Equivalent to Data > Weight Cases. 

Select 
cases 

Extract a set of cases to a new datafile based on some 
criteria, or apply a filter variable. Equivalent to Data > 
Select Cases. 

Value 
labels 

Toggle whether the raw data or the value label is displayed 
in the Data View window. Equivalent to View > Value Labels. 

Use 
variable 
sets 

Select or unselect sets of variables to show in the active 
window. Equivalent to Utilities > Use Variable Sets. Note that 
you must first define a variable set. (Utilities > Define 
Variable Sets) in order for this to be useful. 
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  (Executing Commands in SPSS)                     (تنفیذ الأوامر) :SPSS مقدمة حول مجموعة برامج

SPSS offers two basic ways of working with your data: drop-down menus and syntax 
commands.

• Drop-down menus: Users who are new to SPSS typically learn the software 
by using drop-down menus.

• Syntax Commands: Advanced users can interact with SPSS by writing their own 
syntax. Syntax is a command-driven language that tells SPSS what actions to 
perform on the data. 

1. These are the menus that you see across the toolbar at the top of the screen--e.g., File, Edit, View, Data, etc. These menus provide the options you need for performing specific actions on your data. Clicking on any one of the menus will produce a list of menu items. You may then select a 
specific menu item from the list to perform specific actions. 

2. Using syntax commands (rather than drop-down menus) is preferable for several reasons: 
3.  • Syntax allows users to write commands that are not available via drop-down menus. 
4.  • Syntax provides a useful log of what steps you have taken while working with your data. 
5.  • Syntax allows you to easily edit your commands, in any order, rather than having to re-select each drop-down command if you decide to change some part of your analysis. 
6.  • Syntax allows you to consistently reproduce your commands, which is important for validating your methods. 
7. Overall, syntax offers more flexibility, a clearer record, and greater ease in making changes and re-running commands. It does take some practice to learn to write the basic command language, but once you learn the language the benefits of working with data in this way will become very clear.
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  (The Data View Window)                     (شاشة عرض البیانات) :SPSS مقدمة حول مجموعة برامج

Reading the Data View: When you view data in SPSS, each row in the Data View 
represents a case, and each column represents a variable.

1. Cases represent independent observations, experimental units, or subjects.
2. Variables are attributes, characteristics, or measurements that describe cases.

1. For example: if the data are based on a survey of college students, then each row in the data would represent a specific college student who participated in the study.  
2. For example: your data might include information such as each college student’s date of birth, grade point average (GPA), date of enrollment, and date of graduation. Each of these pieces of information is a variable that describes each case (college student).
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 (Viewing Multiple Sections)                 (شاشة عرض متعددة) :SPSS مقدمة حول مجموعة برامج

View multiple sections of your data simultaneously: The Split option allows you to divide 
the Data View window into multiple sections that can be viewed simultaneously, 
click Window > Split.

1. Now the Data Editor window is partitioned into four sections. The upper and lower sections, as well as the left and right sections, are controlled by separate scroll bars.



المركز الجامعي لميلة

مدخل تعريفي بمجموعة برامج (SPSS)المحور رقم (02)

 (Looking for specific Case or variable)     السجل والمتغیر  :SPSS مقدمة حول مجموعة برامج

SPSS provides a way of quickly jumping to specific cases or variables in your dataset 
in the Data View window.

To jump to a specific case number:

1. Click the Go to case icon
Click Edit > Go to Case.

or 

2. Enter the case number
3. Click Go

To jump to a specific variable number:

1. Click the Go to variable icon
Click Edit > Go to variable.

or 

2. Enter the variable number
3. Click Go

1. This is an especially useful option for large datasets that include hundreds of cases and variables.
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 (Using SPSS Syntax)                         SPSS لغة البرمجة في  :SPSS مقدمة حول مجموعة برامج

SPSS syntax is a programming language that is unique to SPSS. It allows you to write 
commands that run SPSS procedures, rather than using the graphical user interface.

In SPSS syntax, placing an asterisk (*) or a forward-slash followed by an asterisk (/*) at 
the start of a line will turn all text on that line into a comment. Hitting the Enter key will 
create a new, un-commented line. Typically, comments in SPSS syntax are color-coded 
with the color gray.

Dark blue/purple Procedure names; execution statements
Green Statements associated with the given procedure
Dark red/orange Option keywords
Gray Comments
Black Variable names; other text

1. TIP: You can view the content of a syntax file (*.sps) using a text editor like Notepad or Notepad++, even on computers that do not have SPSS installed. 
2. Note: You can copy the syntax from an output window and paste it into a new Syntax Editor window to re-use, modify, and save the syntax. To copy syntax from the output (in the Output Viewer window), simply click the syntax, copy it, and paste it into a Syntax Editor window. 
3. In general, if you are working on a major project (like a thesis, dissertation, or research for publication), or if you are collaborating with others on data analysis, we strongly recommend using SPSS syntax.
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 (Using SPSS Syntax)                         SPSS لغة البرمجة في  :SPSS مقدمة حول مجموعة برامج

OPENING THE SYNTAX EDITOR
To open a new Syntax Editor window, click File > New > Syntax.

EXECUTING SYNTAX COMMANDS
To execute (or run) the commands, highlight the lines you want to run, then click Run > 
Selection, or press Ctrl + R on your keyboard.

1. After you've opened a Syntax Editor window, you can start writing your syntax directly in this window. Alternatively, you can generate syntax while using the graphical user interface: almost all SPSS procedures accessed through the dropdown menus can generate syntax by clicking the 
Paste button instead of clicking OK/Run. After clicking the Paste button, the new syntax will automatically be added to your open Syntax Editor window.
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